LiteSpeed Cache <= 7.9.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via VPI Image Attribute Re-Serialization
Strategic Overview
- Status
- Patched in 7.9.2
- Affected Plugin
- LiteSpeed Cache
- Affected Version
<= 7.9.1- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-109215
At a glance
CVE-2026-109215 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the LiteSpeed Cache WordPress plugin, affecting versions <= 7.9.1. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 7.9.2; sites on affected versions should update now. Disclosed October 2026, reported by Adrien Brunner.
Vulnerability Overview
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has enabled Viewport Images (VPI) and configured a VPI filename that matches an image the attacker can embed in user-generated content — such as a bbPress topic where Subscriber-level Participants are permitted to post replies containing raw img tags.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
LiteSpeed Cache <= 7.9.1 carries this weakness at bbp_reply_content, and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For LiteSpeed Cache the fix is 7.9.2: builds <= 7.9.1 are affected, anything from 7.9.2 onward is not.
Remediation
Update to version 7.9.2, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: LiteSpeed Cache 7.9.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2026-113500: LiteSpeed Cache < 7.9.2 Stored Cross-Site Scripting
CVE-2026-113500 - 7.2CVE-2026-113499: LiteSpeed Cache < 7.9.2 Stored Cross-Site Scripting
CVE-2026-113499 - 7.2CVE-2026-18978: LiteSpeed Cache <= 7.8.1 Stored Cross-Site Scripting
CVE-2026-18978 - 7.2CVE-2026-3375: LiteSpeed Cache <= 7.7 Stored Cross-Site Scripting
CVE-2026-3375
Other vulnerabilities in LiteSpeed Cache
- 9.8CVE-2024-28000: LiteSpeed Cache <= 6.3.0.1 Privilege Escalation
CVE-2024-28000 - 8.1CVE-2024-50550: LiteSpeed Cache <= 6.5.1 Privilege Escalation
CVE-2024-50550 - 7.5CVE-2024-44000: LiteSpeed Cache <= 6.4.1 Info Exposure
CVE-2024-44000 - 7.2CVE-2026-84761: LiteSpeed Cache <= 7.9 Server-Side Request Forgery
CVE-2026-84761 - 7.2CVE-2024-47374: LiteSpeed Cache <= 6.1 Stored Cross-Site Scripting
CVE-2024-47374 - 7.2CVE-2023-40000: LiteSpeed Cache <= 5.7 Stored Cross-Site Scripting
CVE-2023-40000 - 6.5CVE-2021-24964: LiteSpeed Cache <= 4.4.3 Authorization Bypass
CVE-2021-24964 - 6.4CVE-2026-3129: LiteSpeed Cache <= 7.7 Stored Cross-Site Scripting
CVE-2026-3129
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C