JetFormBuilder — Dynamic Blocks Form Builder <= 3.6.7.1 - Unauthenticated Privilege Escalation
Strategic Overview
- Status
- Patched in 3.6.8
- Affected Plugin
- JetFormBuilder — Dynamic Blocks Form Builder
- Affected Version
<= 3.6.7.1- CVSS
- 7.3High
- Weakness type
- CWE-269 · Improper Privilege Management
- CVE
CVE-2026-119481
At a glance
CVE-2026-119481 is a high-severity Improper Privilege Management vulnerability in the JetFormBuilder WordPress plugin, affecting versions <= 3.6.7.1. It carries a CVSS score of 7.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.6.8; sites on affected versions should update now. Disclosed November 2026, reported by Jacek Sowiński (dzaku).
Vulnerability Overview
The JetFormBuilder — Dynamic Blocks Form Builder plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.6.7.1. This is due to insufficient restriction on the capabilities a user may grant themselves. This makes it possible for unauthenticated attackers to elevate their privileges beyond those intended for their role.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-269: Improper Privilege Management
Reaching this weakness in JetFormBuilder <= 3.6.7.1 takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.
It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For JetFormBuilder the fix is 3.6.8: builds <= 3.6.7.1 are affected, anything from 3.6.8 onward is not.
Remediation
Update to version 3.6.8, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: JetFormBuilder 3.6.8 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in JetFormBuilder — Dynamic Blocks Form Builder
- 9.8CVE-2026-19859: JetFormBuilder Arbitrary Shortcode Execution
CVE-2026-19859 - 8.8CVE-2026-54196: JetFormBuilder Privilege Escalation
CVE-2026-54196 - 8.8CVE-2026-32525: JetFormBuilder — Dynamic Blocks Form Builder RCE
CVE-2026-32525 - 8.8CVE-2023-37866: JetFormBuilder <= 3.0.8 Privilege Escalation
CVE-2023-37866 - 7.5CVE-2026-4373: JetFormBuilder <= 3.5.6.2 Arbitrary File Read
CVE-2026-4373 - 7.2CVE-2026-119479: JetFormBuilder Arbitrary Shortcode Execution
CVE-2026-119479 - 7.2CVE-2026-97342: JetFormBuilder <= 3.6.5.4 Stored Cross-Site Scripting
CVE-2026-97342 - 7.2CVE-2026-102391: JetFormBuilder Stored XSS
CVE-2026-102391
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C