JetFormBuilder — Dynamic Blocks Form Builder <= 3.6.7.1 - Unauthenticated Arbitrary Shortcode Execution
Strategic Overview
- Status
- Patched in 3.6.8
- Affected Plugin
- JetFormBuilder — Dynamic Blocks Form Builder
- Affected Version
<= 3.6.7.1- CVSS
- 7.2High
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-119479
At a glance
CVE-2026-119479 is a high-severity Improper Control of Generation of Code vulnerability in the JetFormBuilder WordPress plugin, affecting versions <= 3.6.7.1. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.6.8; sites on affected versions should update now. Disclosed October 2026, reported by Askar.
Vulnerability Overview
The JetFormBuilder — Dynamic Blocks Form Builder plugin for WordPress is vulnerable to Arbitrary Shortcode Execution in all versions up to, and including, 3.6.7.1. This is due to missing tokenization of user-supplied macro values before do_shortcode() execution, allowing submitted field values to be interpreted as shortcode syntax. This makes it possible for unauthenticated attackers to inject arbitrary shortcodes through form field values that are executed on the server when processed by Send Email, Call Webhook, Redirect To Page, or Media field settings.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
JetFormBuilder <= 3.6.7.1 carries this weakness at do_shortcode(), and reaching it takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For JetFormBuilder the fix is 3.6.8: builds <= 3.6.7.1 are affected, anything from 3.6.8 onward is not.
Remediation
Update to version 3.6.8, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: JetFormBuilder 3.6.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Same weakness class
Other vulnerabilities in JetFormBuilder — Dynamic Blocks Form Builder
- 9.8CVE-2026-12793: JetFormBuilder <= 3.6.2 Privilege Escalation
CVE-2026-12793 - 8.8CVE-2026-54196: JetFormBuilder Privilege Escalation
CVE-2026-54196 - 8.8CVE-2023-37866: JetFormBuilder <= 3.0.8 Privilege Escalation
CVE-2023-37866 - 7.5CVE-2026-4373: JetFormBuilder <= 3.5.6.2 Arbitrary File Read
CVE-2026-4373 - 7.2CVE-2026-97342: JetFormBuilder <= 3.6.5.4 Stored Cross-Site Scripting
CVE-2026-97342 - 7.2CVE-2026-102391: JetFormBuilder Stored XSS
CVE-2026-102391 - 7.2CVE-2026-84817: JetFormBuilder Stored XSS
CVE-2026-84817 - 7.2CVE-2026-19861: JetFormBuilder Stored XSS
CVE-2026-19861
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C