JetFormBuilder <= 3.6.5.2 - Authenticated (Administrator+) Arbitrary File Deletion
Strategic Overview
- Status
- Patched in 3.6.5.3
- Affected Plugin
- JetFormBuilder — Dynamic Blocks Form Builder
- Affected Version
<= 3.6.5.2- CVSS
- 6.5Medium
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory
- CVE
CVE-2026-19860
At a glance
CVE-2026-19860 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory vulnerability in the JetFormBuilder WordPress plugin, affecting versions <= 3.6.5.2. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high integrity, availability impact). Exploitation requires an authenticated account at Administrator level or above. The issue is fixed in version 3.6.5.3; sites on affected versions should update now. Disclosed September 2026, reported by Sai Praneeth Koti.
Vulnerability Overview
The JetFormBuilder plugin for WordPress is vulnerable to Arbitrary File Deletion due to insufficient file path validation in all versions up to, and including, 3.6.5.2. This makes it possible for authenticated attackers, with administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on integrity, availability.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory
Reaching this weakness in JetFormBuilder <= 3.6.5.2 takes an account at Administrator level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For JetFormBuilder the fix is 3.6.5.3: builds <= 3.6.5.2 are affected, anything from 3.6.5.3 onward is not.
Remediation
Update to version 3.6.5.3, or a newer patched version
How does WordSec protect against this?
An attacker needs Administrator access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: JetFormBuilder 3.6.5.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in JetFormBuilder — Dynamic Blocks Form Builder
- 9.8CVE-2026-12793: JetFormBuilder <= 3.6.2 Privilege Escalation
CVE-2026-12793 - 9.8CVE-2026-19859: JetFormBuilder Arbitrary Shortcode Execution
CVE-2026-19859 - 8.8CVE-2026-54196: JetFormBuilder Privilege Escalation
CVE-2026-54196 - 8.8CVE-2026-32525: JetFormBuilder — Dynamic Blocks Form Builder RCE
CVE-2026-32525 - 8.8CVE-2023-37866: JetFormBuilder <= 3.0.8 Privilege Escalation
CVE-2023-37866 - 7.5CVE-2026-4373: JetFormBuilder <= 3.5.6.2 Arbitrary File Read
CVE-2026-4373 - 7.3CVE-2026-119481: JetFormBuilder Privilege Escalation
CVE-2026-119481 - 7.2CVE-2026-111317: JetFormBuilder <= 3.6.7 Stored Cross-Site Scripting
CVE-2026-111317
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C