GeoDirectory <= 2.8.200 - Unauthenticated Stored Cross-Site Scripting via Nested '[gd_dynamic_content]' Shortcode in post_content
Strategic Overview
- Status
- Patched in 2.8.201
- Affected Version
<= 2.8.200- CVSS
- 7.2High
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-120082
At a glance
CVE-2026-120082 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.200. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.8.201; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.
Vulnerability Overview
The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_content' parameter in all versions up to, and including, 2.8.200 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The nested shortcode payload ([gd_dynamic_conten[gd_tags]t ...]) defeats the plugin's geodir_strip_shortcodes() guard because WordPress's strip_shortcodes() performs only a single pass over registered tags, and HTML-entity-encoded attributes in the resulting shortcode survive wp_kses_post() because kses inspects HTML tags rather than shortcode attribute values.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
GeoDirectory <= 2.8.200 carries this weakness at post_content, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For GeoDirectory the fix is 2.8.201: builds <= 2.8.200 are affected, anything from 2.8.201 onward is not.
Remediation
Update to version 2.8.201, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: GeoDirectory 2.8.201 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
- 9.9CVE-2024-43145: GeoDirectory <= 2.3.61 SQL Injection
CVE-2024-43145 - 8.1CVE-2026-104899: GeoDirectory <= 2.8.187 Local File Inclusion
CVE-2026-104899 - 8.1CVE-2026-19091: GeoDirectory <= 2.8.169 Arbitrary File Deletion
CVE-2026-19091 - 7.5CVE-2026-103913: GeoDirectory <= 2.8.186 SQL Injection
CVE-2026-103913 - 7.5CVE-2026-84813: GeoDirectory SQL Injection
CVE-2026-84813 - 7.5CVE-2026-54831: GeoDirectory SQL Injection
CVE-2026-54831 - 7.5CVE-2026-39512: GeoDirectory SQL Injection
CVE-2026-39512 - 7.5CVE-2024-13507: GeoDirectory SQL Injection
CVE-2024-13507
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C