CVE-2026-116752

GeoDirectory <= 2.8.197 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'post_images' Image Title Delimiter Injection

2026-10-30 20:46
mamgad (mamgad)

Strategic Overview

Status
Patched in 2.8.198
Affected Version
<= 2.8.197
CVSS
6.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-116752
View all GeoDirectory – WP Business Directory Plugin and Classified Listings Directory vulnerabilities

At a glance

CVE-2026-116752 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.197. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.8.198; sites on affected versions should update now. Disclosed October 2026, reported by mamgad (mamgad).

Vulnerability Overview

The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_images' parameter in all versions up to, and including, 2.8.197 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload does not fire for the attacker directly; it executes in the browser of any Administrator or Editor who opens the pending listing's edit screen, making this a privilege-escalation-capable stored XSS chain triggered through normal editorial workflow.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

GeoDirectory <= 2.8.197 carries this weakness at post_images, and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For GeoDirectory the fix is 2.8.198: builds <= 2.8.197 are affected, anything from 2.8.198 onward is not.

Remediation

Update to version 2.8.198, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: GeoDirectory 2.8.198 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C