GeoDirectory <= 2.8.193 - Authenticated (Subscriber+) Arbitrary Media File Read
Strategic Overview
- Status
- Patched in 2.8.194
- Affected Version
<= 2.8.193- CVSS
- 6.5Medium
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
- CVE
CVE-2026-113491
At a glance
CVE-2026-113491 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.193. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.8.194; sites on affected versions should update now. Disclosed October 2026, reported by vuxvinh.
Vulnerability Overview
The GeoDirectory plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 2.8.193. This is due to insufficient validation of a user supplied path. This makes it possible for authenticated attackers, with subscriber-level access and above, to read arbitrary media files on the server.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Reaching this weakness in GeoDirectory <= 2.8.193 takes an account at Subscriber level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For GeoDirectory the fix is 2.8.194: builds <= 2.8.193 are affected, anything from 2.8.194 onward is not.
Remediation
Update to version 2.8.194, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: GeoDirectory 2.8.194 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
- 9.9CVE-2024-43145: GeoDirectory <= 2.3.61 SQL Injection
CVE-2024-43145 - 8.1CVE-2026-104899: GeoDirectory <= 2.8.187 Local File Inclusion
CVE-2026-104899 - 7.5CVE-2026-103913: GeoDirectory <= 2.8.186 SQL Injection
CVE-2026-103913 - 7.5CVE-2026-84813: GeoDirectory SQL Injection
CVE-2026-84813 - 7.5CVE-2026-54831: GeoDirectory SQL Injection
CVE-2026-54831 - 7.5CVE-2026-39512: GeoDirectory SQL Injection
CVE-2026-39512 - 7.5CVE-2024-13507: GeoDirectory SQL Injection
CVE-2024-13507 - 7.2CVE-2026-113673: GeoDirectory <= 2.8.193 Remote Code Execution
CVE-2026-113673
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C