GeoDirectory <= 2.8.193 - Authenticated (Administrator+) Remote Code Execution
Strategic Overview
- Status
- Patched in 2.8.194
- Affected Version
<= 2.8.193- CVSS
- 7.2High
- Weakness type
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
- CVE
CVE-2026-113673
At a glance
CVE-2026-113673 is a high-severity Improper Control of Generation of Code ('Code Injection') vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.193. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Administrator level or above. The issue is fixed in version 2.8.194; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.
Vulnerability Overview
The GeoDirectory plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 2.8.193. This is due to insufficient validation of user supplied input before it is executed. This makes it possible for authenticated attackers, with administrator-level access and above, to execute arbitrary code on the server.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-94: Improper Control of Generation of Code ('Code Injection')
Reaching this weakness in GeoDirectory <= 2.8.193 takes an account at Administrator level or above. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For GeoDirectory the fix is 2.8.194: builds <= 2.8.193 are affected, anything from 2.8.194 onward is not.
Remediation
Update to version 2.8.194, or a newer patched version
How does WordSec protect against this?
An attacker needs Administrator access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: GeoDirectory 2.8.194 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
- 9.9CVE-2024-43145: GeoDirectory <= 2.3.61 SQL Injection
CVE-2024-43145 - 8.1CVE-2026-104899: GeoDirectory <= 2.8.187 Local File Inclusion
CVE-2026-104899 - 8.1CVE-2026-19091: GeoDirectory <= 2.8.169 Arbitrary File Deletion
CVE-2026-19091 - 7.5CVE-2026-103913: GeoDirectory <= 2.8.186 SQL Injection
CVE-2026-103913 - 7.5CVE-2026-84813: GeoDirectory SQL Injection
CVE-2026-84813 - 7.5CVE-2026-54831: GeoDirectory SQL Injection
CVE-2026-54831 - 7.5CVE-2026-39512: GeoDirectory SQL Injection
CVE-2026-39512 - 7.5CVE-2024-13507: GeoDirectory SQL Injection
CVE-2024-13507
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C