CVE-2026-110001

FV Flowplayer Video Player <= 7.5.55.7212 - Unauthenticated Stored Cross-Site Scripting via 'align' Shortcode Attribute

2026-10-30 17:04
Kuba

Strategic Overview

Status
Patched in 7.5.56.7212
Affected Version
<= 7.5.55.7212
CVSS
5.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-110001
View all FV Flowplayer Video Player vulnerabilities

At a glance

CVE-2026-110001 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the FV Flowplayer Video Player WordPress plugin, affecting versions <= 7.5.55.7212. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 7.5.56.7212; sites on affected versions should update now. Disclosed October 2026, reported by Kuba.

Vulnerability Overview

The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment (shortcode attribute 'align')' parameter in all versions up to, and including, 7.5.55.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the plugin's 'Parse Vimeo and YouTube links' (parse_comments) setting to be enabled by an administrator, which causes the plugin to register do_shortcode on the comment_text filter, allowing attacker-supplied shortcode attributes stored in comments to be rendered unescaped to all subsequent visitors.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

FV Flowplayer Video Player <= 7.5.55.7212 carries this weakness at align, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For FV Flowplayer Video Player the fix is 7.5.56.7212: builds <= 7.5.55.7212 are affected, anything from 7.5.56.7212 onward is not.

Remediation

Update to version 7.5.56.7212, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: FV Flowplayer Video Player 7.5.56.7212 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C