Enable Media Replace <= 4.2.2 - Missing Authorization to Authenticated (Author+) Post Content Modification via Media Replacement Workflow
Strategic Overview
- Status
- Patched in 4.2.3
- Affected Plugin
- Enable Media Replace
- Affected Version
<= 4.2.2- CVSS
- 4.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-85655
At a glance
CVE-2026-85655 is a medium-severity Missing Authorization vulnerability in the Enable Media Replace WordPress plugin, affecting versions <= 4.2.2. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Author level or above. The issue is fixed in version 4.2.3; sites on affected versions should update now. Disclosed October 2026, reported by Duy Tran.
Vulnerability Overview
The Enable Media Replace plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.2. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to modify the post_content of any published post referencing the replaced media — including Administrator-owned posts — making changes immediately visible to unauthenticated visitors. The doReplaceQuery() method performs a database-wide search-and-replace across all posts containing the old media URL without any per-post capability check, meaning a single Author-triggered request can silently overwrite a large number of posts that WordPress's standard admin UI and REST API would otherwise forbid that user from editing.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-862: Missing Authorization
Enable Media Replace <= 4.2.2 carries this weakness at doReplaceQuery(), and reaching it takes an account at Author level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Enable Media Replace the fix is 4.2.3: builds <= 4.2.2 are affected, anything from 4.2.3 onward is not.
Remediation
Update to version 4.2.3, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Enable Media Replace 4.2.3 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Enable Media Replace
- 8.8CVE-2023-0255: Enable Media Replace <= 4.0.1 Arbitrary File Upload
CVE-2023-0255 - 6.8CVE-2022-2554: Enable Media Replace <= 3.6.3 Path Traversal
CVE-2022-2554 - 6.6CVE-2023-4643: Enable Media Replace <= 4.1.2 PHP Object Injection
CVE-2023-4643 - 6.4CVE-2026-5714: Enable Media Replace <= 4.1.8 Stored XSS
CVE-2026-5714 - 6.4CVE-2025-9496: Enable Media Replace <= 4.1.6 Stored XSS
CVE-2025-9496 - 6.1CVE-2025-31081: Enable Media Replace <= 4.1.5 Reflected XSS
CVE-2025-31081 - 4.7CVE-2023-6737: Enable Media Replace <= 4.1.4 Reflected XSS
CVE-2023-6737 - 4.4CVE-2026-57722: Enable Media Replace <= 4.2.1 Stored XSS
CVE-2026-57722
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C