CVE-2026-12470

CMP <= 4.1.17 - Authenticated (Editor+) Privilege Escalation via Arbitrary Option Update to cmp_ajax_import_settings AJAX Action

2026-09-21 16:45
Như Nguyễn

Strategic Overview

Status
Patched in 4.1.18
Affected Version
<= 4.1.17
CVSS
7.2High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-12470
View all CMP – Coming Soon & Maintenance Plugin by NiteoThemes vulnerabilities

At a glance

CVE-2026-12470 is a high-severity Improper Privilege Management vulnerability in the CMP WordPress plugin, affecting versions <= 4.1.17. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Editor level or above. The issue is fixed in version 4.1.18; sites on affected versions should update now. Disclosed September 2026, reported by Như Nguyễn.

Vulnerability Overview

The CMP – Coming Soon & Maintenance Plugin by NiteoThemes plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'cmp_ajax_import_settings' AJAX action in all versions up to, and including, 4.1.17. This makes it possible for authenticated attackers, with Editor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

CMP <= 4.1.17 carries this weakness at cmp_ajax_import_settings, and reaching it takes an account at Editor level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For CMP the fix is 4.1.18: builds <= 4.1.17 are affected, anything from 4.1.18 onward is not.

Remediation

Update to version 4.1.18, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: CMP 4.1.18 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C