Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content <= 0.8.8 - Unauthenticated Arbitrary Content Injection
Strategic Overview
- Status
- Patched in 0.8.9
- Affected Plugin
- Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content
- Affected Version
<= 0.8.8- CVSS
- 5.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-48202
At a glance
CVE-2026-48202 is a medium-severity Missing Authorization vulnerability in the Brave WordPress plugin, affecting versions <= 0.8.8. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 0.8.9; sites on affected versions should update now. Disclosed October 2026, reported by Peter Tang.
Vulnerability Overview
The Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content plugin for WordPress is vulnerable to Arbitrary Content Injection in all versions up to, and including, 0.8.8. This is due to missing server-side validation of the user-controlled quizData POST parameter, which was decoded and used directly instead of being derived from trusted server-side form field definitions. This makes it possible for unauthenticated attackers to inject arbitrary content into form submission outputs such as notification emails by supplying a crafted quizData POST parameter. A Brave popup with a form must be published and accessible on the site.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in Brave <= 0.8.8 takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Brave the fix is 0.8.9: builds <= 0.8.8 are affected, anything from 0.8.9 onward is not.
Remediation
Update to version 0.8.9, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Brave 0.8.9 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content
- 7.2CVE-2024-30453: Brave Popup Builder <= 0.6.5 SSRF
CVE-2024-30453 - 6.5CVE-2026-81571: Brave Popup Builder Arbitrary Shortcode Execution
CVE-2026-81571 - 6.1CVE-2026-77115: Brave Reflected XSS
CVE-2026-77115 - 4.4CVE-2024-35655: Brave Stored XSS
CVE-2024-35655 - 4.4CVE-2023-51534: Brave Popup Builder <= 0.6.2 Stored XSS
CVE-2023-51534 - 4.3CVE-2026-77116: Brave Popup Builder <= 0.8.5 IDOR
CVE-2026-77116 - 4.3CVE-2024-43337: Brave Popup Builder <= 0.7.0 CSRF
CVE-2024-43337
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C