Brave Popup Builder <= 0.8.7 - Unauthenticated Arbitrary Shortcode Execution
Strategic Overview
- Status
- Patched in 0.8.8
- Affected Plugin
- Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content
- Affected Version
<= 0.8.7- CVSS
- 6.5Medium
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-81571
At a glance
CVE-2026-81571 is a medium-severity Improper Control of Generation of Code vulnerability in the Brave WordPress plugin, affecting versions <= 0.8.7. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 0.8.8; sites on affected versions should update now. Disclosed August 2026, reported by Erwan LR.
Vulnerability Overview
The Brave Popup Builder plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 0.8.7. This is due to passing a user-controlled URL parameter through do_shortcode() before output in a hidden form field without authentication. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes registered on the site by supplying a crafted UTM parameter that pre-fills a hidden form field.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
Brave <= 0.8.7 carries this weakness at do_shortcode(), and reaching it takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Brave the fix is 0.8.8: builds <= 0.8.7 are affected, anything from 0.8.8 onward is not.
Remediation
Update to version 0.8.8, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Brave 0.8.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Other vulnerabilities in Brave – Create Popup, Optins, Lead Generation, Survey, Sticky Elements & Interactive Content
- 7.2CVE-2024-30453: Brave Popup Builder <= 0.6.5 SSRF
CVE-2024-30453 - 6.1CVE-2026-77115: Brave Reflected XSS
CVE-2026-77115 - 5.3CVE-2025-68508: Brave <= 0.8.3 Missing Authorization
CVE-2025-68508 - 4.4CVE-2024-35655: Brave Stored XSS
CVE-2024-35655 - 4.4CVE-2023-51534: Brave Popup Builder <= 0.6.2 Stored XSS
CVE-2023-51534 - 4.3CVE-2026-77116: Brave Popup Builder <= 0.8.5 IDOR
CVE-2026-77116 - 4.3CVE-2024-43337: Brave Popup Builder <= 0.7.0 CSRF
CVE-2024-43337
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C