CVE-2026-11984

Ad Inserter <= 2.8.16 - Missing Authorization to Unauthenticated Header/Footer Code Disclosure via 'ai-debug-code' Parameter

2026-09-15 15:24
Evan

Strategic Overview

Status
Patched in 2.8.17
Affected Version
<= 2.8.16
CVSS
5.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-11984
View all Ad Inserter – Ad Manager & AdSense Ads vulnerabilities

At a glance

CVE-2026-11984 is a medium-severity Missing Authorization vulnerability in the Ad Inserter WordPress plugin, affecting versions <= 2.8.16. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.8.17; sites on affected versions should update now. Disclosed September 2026, reported by Evan.

Vulnerability Overview

The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.8.16 due to a missing capability check on the `ai-debug-code` URL-parameter. This makes it possible for unauthenticated attackers to view administrator-configured header and footer code blocks that have been disabled from public display.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Ad Inserter <= 2.8.16 takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Ad Inserter the fix is 2.8.17: builds <= 2.8.16 are affected, anything from 2.8.17 onward is not.

Remediation

Update to version 2.8.17, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Ad Inserter 2.8.17 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C