Ad Inserter <= 2.8.19 - Unauthenticated Arbitrary Shortcode Execution via 's' Search Parameter
Strategic Overview
- Status
- Patched in 2.8.20
- Affected Plugin
- Ad Inserter – Ad Manager & AdSense Ads
- Affected Version
<= 2.8.19- CVSS
- 6.5Medium
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-102905
At a glance
CVE-2026-102905 is a medium-severity Improper Control of Generation of Code vulnerability in the Ad Inserter WordPress plugin, affecting versions <= 2.8.19. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.8.20; sites on affected versions should update now. Disclosed October 2026, reported by Kuba.
Vulnerability Overview
The The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.19 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires an administrator to have configured an ad block containing a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} with display enabled on search pages, which is a normal and documented plugin configuration.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
Reaching this weakness in Ad Inserter <= 2.8.19 takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Ad Inserter the fix is 2.8.20: builds <= 2.8.19 are affected, anything from 2.8.20 onward is not.
Remediation
Update to version 2.8.20, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Ad Inserter 2.8.20 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Same weakness class
Other vulnerabilities in Ad Inserter – Ad Manager & AdSense Ads
- 8.8CVE-2015-9497: Ad Inserter CSRF to Cross-Site Scripting
CVE-2015-9497 - 7.5CVE-2019-15323: Ad Inserter <= 2.4.19 Path Traversal
CVE-2019-15323 - 7.2CVE-2026-97077: Ad Inserter – Ad Manager & AdSense Ads Stored XSS
CVE-2026-97077 - 7.2CVE-2023-1549: Ad Inserter <= 2.7.25 PHP Object Injection
CVE-2023-1549 - 6.4CVE-2026-107864: Ad Inserter – Ad Manager & AdSense Ads Stored XSS
CVE-2026-107864 - 6.4CVE-2026-81655: Ad Inserter 2.8.12 - 2.8.18 Stored XSS
CVE-2026-81655 - 6.4CVE-2026-57693: Ad Inserter – Ad Manager & AdSense Ads Stored XSS
CVE-2026-57693 - 6.4CVE-2025-11745: Ad Inserter <= 2.8.7 Stored Cross-Site Scripting
CVE-2025-11745
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C