CVE-2026-2839

Advanced Custom Fields: Extended <= 0.9.2.7 - Missing Authorization to Unauthenticated Data Exposure via Multiple AJAX Endpoints

2026-10-27 00:00
Jay

Strategic Overview

Status
Patched in 0.9.2.8
Affected Version
<= 0.9.2.7
CVSS
5.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-2839
View all Advanced Custom Fields: Extended vulnerabilities

At a glance

CVE-2026-2839 is a medium-severity Missing Authorization vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions <= 0.9.2.7. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 0.9.2.8; sites on affected versions should update now. Disclosed October 2026, reported by Jay.

Vulnerability Overview

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Advanced Custom Fields <= 0.9.2.7 carries this weakness at current_user_can(), and reaching it takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Advanced Custom Fields the fix is 0.9.2.8: builds <= 0.9.2.7 are affected, anything from 0.9.2.8 onward is not.

Remediation

Update to version 0.9.2.8, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.8 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C