Advanced Custom Fields: Extended <= 0.9.2.6 - Missing Authorization to Unauthenticated Arbitrary Attachment Deletion via Email Action Dynamic File Field
Strategic Overview
- Status
- Patched in 0.9.2.7
- Affected Plugin
- Advanced Custom Fields: Extended
- Affected Version
<= 0.9.2.6- CVSS
- 4.8Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-10752
At a glance
CVE-2026-10752 is a medium-severity Missing Authorization vulnerability in the Advanced Custom Fields WordPress plugin, affecting versions <= 0.9.2.6. It carries a CVSS score of 4.8 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 0.9.2.7; sites on affected versions should update now. Disclosed October 2026, reported by normaandersonfrank.
Vulnerability Overview
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 0.9.2.6. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to permanently delete arbitrary WordPress media library attachments by supplying a numeric attachment ID in the form submission without any ownership or capability verification. Exploitation requires a site administrator to have configured a public-facing ACFE form with an Email action whose attachment row uses a dynamic {field:...} source bound to a submittable field with the Delete option enabled.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in Advanced Custom Fields <= 0.9.2.6 takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Advanced Custom Fields the fix is 0.9.2.7: builds <= 0.9.2.6 are affected, anything from 0.9.2.7 onward is not.
Remediation
Update to version 0.9.2.7, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Advanced Custom Fields 0.9.2.7 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Advanced Custom Fields: Extended
- 9.8CVE-2026-12526: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-12526 - 9.8CVE-2026-8809: Advanced Custom Fields: Extended Privilege Escalation
CVE-2026-8809 - 9.8CVE-2025-14533: Advanced Custom Fields: Extended Privilege Escalation
CVE-2025-14533 - 9.8CVE-2025-13486: Advanced Custom Fields RCE in prepare_form
CVE-2025-13486 - 7.3CVE-2026-80467: Advanced Custom Fields Privilege Escalation
CVE-2026-80467 - 7.2CVE-2026-112313: Advanced Custom Fields: Extended Stored XSS
CVE-2026-112313 - 7.2CVE-2021-24865: Advanced Custom Fields: Extended Admin+ SQL Injection
CVE-2021-24865 - 6.5CVE-2025-15463: Advanced Custom Fields Arbitrary Shortcode Execution
CVE-2025-15463
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C