CVE-2026-120548

YML for Yandex Market <= 5.10.0 - Unauthenticated Sensitive Information Exposure through Log File via 'y4ym_check_action' Parameter via admin-post.php

2026-11-06 21:24
Kuba

Strategic Overview

Status
Patched in 5.11.0
Affected Plugin
YML for Yandex Market
Affected Version
<= 5.10.0
CVSS
5.3Medium
Weakness type
CWE-532 · Insertion of Sensitive Information into Log File
CVE
CVE-2026-120548
View all YML for Yandex Market vulnerabilities

At a glance

CVE-2026-120548 is a medium-severity Insertion of Sensitive Information into Log File vulnerability in the YML for Yandex Market WordPress plugin, affecting versions <= 5.10.0. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 5.11.0; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.

Vulnerability Overview

The YML for Yandex Market plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.10.0 via the 'y4ym_check_action' parameter. This makes it possible for unauthenticated attackers to extract the merchant's plaintext Yandex Market API key written to the publicly accessible log file at wp-content/uploads/y4ym/yml-for-yandex-market.log, granting full control over the merchant's marketplace catalogue, prices, and stock. Exploitation requires that the targeted feed has a stored Yandex Market API key and that the y4ym_keeplogs option is enabled — both conditions that represent normal, documented plugin usage actively encouraged by the plugin's own support and feedback workflow.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-532: Insertion of Sensitive Information into Log File

The product writes sensitive information to a log file.

Remediation

Update to version 5.11.0, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: YML for Yandex Market 5.11.0 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C