WS Form LITE <= 1.12.18 - Unauthenticated Stored Cross-Site Scripting via Text Field Array Value
Strategic Overview
- Status
- Patched in 1.12.19
- Affected Plugin
- WS Form LITE – Drag & Drop Contact Form Builder
- Affected Version
<= 1.12.18- CVSS
- 7.2High
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-122231
At a glance
CVE-2026-122231 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the WS Form LITE WordPress plugin, affecting versions <= 1.12.18. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.12.19; sites on affected versions should update now. Disclosed November 2026, reported by UKO.
Vulnerability Overview
The WS Form LITE – Drag & Drop Contact Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'field_<id>[0][0]' parameter in all versions up to, and including, 1.12.18 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the client-side esc_html() helper returns any non-string value unchanged, allowing a nested-array payload coerced via Array.prototype.toString to reach jQuery .append() unescaped.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
WS Form LITE <= 1.12.18 carries this weakness at esc_html(), and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For WS Form LITE the fix is 1.12.19: builds <= 1.12.18 are affected, anything from 1.12.19 onward is not.
Remediation
Update to version 1.12.19, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WS Form LITE 1.12.19 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2024-13509: WS Form LITE and PRO <= 1.10.13 Stored XSS
CVE-2024-13509 - 7.2CVE-2022-23988: WS Form LITE and WS Form Pro < 1.8.176 Stored XSS
CVE-2022-23988 - 6.1CVE-2024-10647: WS Form LITE Reflected XSS
CVE-2024-10647 - 6.1CVE-2024-47320: WS Form LITE <= 1.9.238 Stored Cross-Site Scripting
CVE-2024-47320
Other vulnerabilities in WS Form LITE – Drag & Drop Contact Form Builder
- 9.8CVE-2026-4703: WS Form LITE <= 1.10.80 PHP Object Injection
CVE-2026-4703 - 6.6CVE-2023-52135: WS Form LITE <= 1.9.170 SQL Injection
CVE-2023-52135 - 5.3CVE-2025-3912: WS Form LITE Unauthenticated Info Exposure
CVE-2025-3912 - 5.3WS Form LITE <= 1.9.117 CAPTCHA Bypass
- 4.8CVE-2022-23987: WS Form LITE and Pro < 1.8.176 Stored XSS
CVE-2022-23987 - 4.7CVE-2023-5424: WS Form LITE <= 1.9.217 CSV Injection
CVE-2023-5424 - 4.3CVE-2026-11562: WS Form LITE Authenticated (Subscriber+) Arbitrary
CVE-2026-11562
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C