WPvivid — Backup, Migration & Staging < 0.9.137 - Authenticated (Administrator+) Arbitrary Database Table Deletion
Strategic Overview
- Status
- Patched in 0.9.137
- Affected Plugin
- WPvivid — Backup, Migration & Staging
- Affected Version
< 0.9.137- CVSS
- 2.7Low
- Weakness type
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
- CVE
CVE-2026-115241
At a glance
CVE-2026-115241 is a low-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the WPvivid WordPress plugin, affecting versions < 0.9.137. It carries a CVSS score of 2.7 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Administrator level or above. The issue is fixed in version 0.9.137; sites on affected versions should update now. Disclosed November 2026, reported by Karthik Ramakrishnan.
Vulnerability Overview
The WPvivid — Backup, Migration & Staging plugin for WordPress is vulnerable to SQL Injection in all versions up to 0.9.137. This is due to missing validation that a caller-supplied snapshot identifier actually corresponds to an existing plugin-created snapshot before using it as a table-name prefix in DROP TABLE queries. This makes it possible for authenticated attackers, with administrator-level access and above, to drop arbitrary database tables, including core WordPress tables, by supplying the site's table prefix as a snapshot identifier, resulting in complete site destruction. The attacker must have Administrator-level access to the WordPress dashboard.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-89: Improper Neutralization of Special Elements used in an SQL Command
Reaching this weakness in WPvivid < 0.9.137 takes an account at Administrator level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.
A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For WPvivid the fix is 0.9.137: builds < 0.9.137 are affected, anything from 0.9.137 onward is not.
Remediation
Update to version 0.9.137, or a newer patched version
How does WordSec protect against this?
An attacker needs Administrator access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WPvivid 0.9.137 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WPvivid — Backup, Migration & Staging
- 9.8CVE-2026-1357: Migration, Backup, Staging Arbitrary File Upload
CVE-2026-1357 - 8.8CVE-2024-10962: Migration, Backup, Staging PHP Object Injection
CVE-2024-10962 - 8.8CVE-2020-36842: Migration, Backup, Staging Arbitrary File Upload
CVE-2020-36842 - 8.7CVE-2023-4274: Migration, Backup, Staging Arbitrary Directory Deletion
CVE-2023-4274 - 8.3CVE-2023-41243: WPvivid Backup Plugin <= 0.9.90 Missing Authorization
CVE-2023-41243 - 8.0CVE-2023-5576: Migration Google Drive Client Secret Exposure
CVE-2023-5576 - 7.5CVE-2026-19725: WPvivid — Backup, Migration & Staging Path Traversal
CVE-2026-19725 - 7.5CVE-2024-7315: Migration, Backup, Staging – WPvivid Info Exposure
CVE-2024-7315
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C