WPJAM Basic <= 7.1 - Unauthenticated Privilege Escalation to 'data[args][role]' Parameter
Strategic Overview
- Status
- Patched in 7.1.2
- Affected Plugin
- WPJAM Basic
- Affected Version
<= 7.1- CVSS
- 8.1High
- Weakness type
- CWE-269 · Improper Privilege Management
- CVE
CVE-2026-103900
At a glance
CVE-2026-103900 is a high-severity Improper Privilege Management vulnerability in the WPJAM Basic WordPress plugin, affecting versions <= 7.1. It carries a CVSS score of 8.1 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 7.1.2; sites on affected versions should update now. Disclosed November 2026, reported by nudien.
Vulnerability Overview
The WPJAM Basic plugin for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 7.1 This is due to the WPJAM_User_Signup::signup() function unpacking attacker-supplied `data[args]` from the AJAX POST body and merging it via PHP array union into the payload passed to WPJAM_User::create(), whose internal whitelist (wpjam_pick) explicitly preserves the `role` key before it is handed to wp_insert_user(). The endpoint is registered as wp_ajax_nopriv_{provider}-signup with a nonce that is emitted on the public login page. This makes it possible for unauthenticated attackers to elevate their privileges to Administrator by creating a new user with an attacker-chosen role, provided a social-login provider is registered and open registration is enabled.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-269: Improper Privilege Management
WPJAM Basic <= 7.1 carries this weakness at signup(), and reaching it takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.
It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For WPJAM Basic the fix is 7.1.2: builds <= 7.1 are affected, anything from 7.1.2 onward is not.
Remediation
Update to version 7.1.2, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: WPJAM Basic 7.1.2 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in WPJAM Basic
- 8.8CVE-2026-32523: WPJAM Basic <= 6.9.2 Arbitrary File Upload
CVE-2026-32523 - 7.5CVE-2026-57371: WPJAM Basic <= 7.0 PHP Object Injection
CVE-2026-57371 - 7.2CVE-2026-57372: WPJAM Basic <= 7.0 Server-Side Request Forgery
CVE-2026-57372 - 6.5CVE-2026-61966: WPJAM Basic <= 7.0.1 SQL Injection
CVE-2026-61966 - 6.4CVE-2023-23709: WPJAM Basic <= 6.2.1 Stored Cross-Site Scripting
CVE-2023-23709 - 4.3CVE-2026-66432: WPJAM Basic <= 7.0.2.1 Information Exposure
CVE-2026-66432
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C