WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell <= 3.13.5 - Cross-Site Request Forgery
Strategic Overview
- Status
- Patched in 3.13.6
- Affected Version
<= 3.13.5- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery
- CVE
CVE-2026-27062
At a glance
CVE-2026-27062 is a medium-severity Cross-Site Request Forgery vulnerability in the WPFunnels WordPress plugin, affecting versions <= 3.13.5. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.13.6; sites on affected versions should update now. Disclosed October 2026, reported by mamgad.
Vulnerability Overview
The WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.13.5. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery
Reaching this weakness in WPFunnels <= 3.13.5 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For WPFunnels the fix is 3.13.6: builds <= 3.13.5 are affected, anything from 3.13.6 onward is not.
Remediation
Update to version 3.13.6, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to WPFunnels: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WPFunnels 3.13.6 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell
- 9.8CVE-2026-14345: WPFunnels <= 3.12.7 Remote Code Execution
CVE-2026-14345 - 9.8CVE-2025-47530: WPFunnels <= 3.5.18 PHP Object Injection
CVE-2025-47530 - 8.8CVE-2026-15103: WPFunnels <= 3.12.8 Privilege Escalation
CVE-2026-15103 - 7.2CVE-2026-97271: WPFunnels Stored XSS
CVE-2026-97271 - 6.6CVE-2026-13080: WPFunnels <= 3.12.7 Local File Inclusion
CVE-2026-13080 - 6.5CVE-2025-12000: WPFunnels <= 3.6.2 Arbitrary File Deletion
CVE-2025-12000 - 6.4CVE-2026-62029: WPFunnels Stored XSS
CVE-2026-62029 - 6.4CVE-2026-0626: WPFunnels <= 3.7.9 Stored Cross-Site Scripting
CVE-2026-0626
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C