CVE-2026-103962

User Frontend <= 4.3.13 - Reflected Cross-Site Scripting via 'field_attr[required]' Parameter

2026-10-30 19:34
Dthangws

At a glance

CVE-2026-103962 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the User Frontend WordPress plugin, affecting versions <= 4.3.13. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.3.14; sites on affected versions should update now. Disclosed October 2026, reported by Dthangws.

Vulnerability Overview

The User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'field_attr[required]' parameter in all versions up to, and including, 4.3.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The nonce check on the wpuf_get_child_cat AJAX action is not an effective security barrier because the wpuf_nonce value is publicly localized to every anonymous visitor of any page containing a WPUF shortcode, making it freely harvestable by an unauthenticated attacker.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-79: Improper Neutralization of Input During Web Page Generation

User Frontend <= 4.3.13 carries this weakness at field_attr[required], and reaching it takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For User Frontend the fix is 4.3.14: builds <= 4.3.13 are affected, anything from 4.3.14 onward is not.

Remediation

Update to version 4.3.14, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to User Frontend: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: User Frontend 4.3.14 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C