Wp Ultimate Review <= 2.0.3 - Cross-Site Request Forgery
Strategic Overview
- Status
- Patched in 2.1.0
- Affected Plugin
- WP Ultimate Review
- Affected Version
<= 2.0.3- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery (CSRF)
- CVE
CVE-2023-28987
At a glance
CVE-2023-28987 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the WP Ultimate Review WordPress plugin, affecting versions <= 2.0.3. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.1.0; sites on affected versions should update now. Disclosed March 2023, reported by Kévin Mosbahi (Mika).
Vulnerability Overview
The Wp Ultimate Review plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.3. This is due to missing nonce validation on several functions like wur_settings_view(). This makes it possible for unauthenticated attackers to perform unauthorized actions like modifying the plugin's settings, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery (CSRF)
WP Ultimate Review <= 2.0.3 carries this weakness at wur_settings_view(), and reaching it takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For WP Ultimate Review the fix is 2.1.0: builds <= 2.0.3 are affected, anything from 2.1.0 onward is not.
Remediation
Update to version 2.1.0, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to WP Ultimate Review: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WP Ultimate Review 2.1.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WP Ultimate Review
- 8.1CVE-2026-92235: WP Ultimate Review Arbitrary Shortcode Execution
CVE-2026-92235 - 7.2CVE-2026-101159: Ultimate Review <= 2.4.3 Stored Cross-Site Scripting
CVE-2026-101159 - 6.5CVE-2026-103234: Ultimate Review Arbitrary Shortcode Execution
CVE-2026-103234 - 6.5CVE-2026-100157: WP Ultimate Review Arbitrary Shortcode Execution
CVE-2026-100157 - 6.4CVE-2026-101162: Ultimate Review <= 2.4.3 Stored Cross-Site Scripting
CVE-2026-101162 - 6.4CVE-2025-63057: Ultimate Review <= 2.3.7 Stored Cross-Site Scripting
CVE-2025-63057 - 5.4CVE-2026-103519: WP Ultimate Review Arbitrary Shortcode Execution
CVE-2026-103519 - 5.3CVE-2026-101160: Ultimate Review <= 2.4.3 Persistent Denial of Service
CVE-2026-101160
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C