CVE-2026-120040

Mail logging & Catcher <= 2.2.0 - Authenticated (Subscriber+) Sensitive Information Exposure to Privilege Escalation to Mail Log Viewer / Password-Reset Email Disclosure

2026-10-30 18:37
Duc Manh

Strategic Overview

Status
Patched in 2.3.0
Affected Plugin
Mail logging & Catcher
Affected Version
<= 2.2.0
CVSS
7.5High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-120040
View all Mail logging & Catcher vulnerabilities

At a glance

CVE-2026-120040 is a high-severity Improper Privilege Management vulnerability in the Mail logging & Catcher WordPress plugin, affecting versions <= 2.2.0. It carries a CVSS score of 7.5 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.3.0; sites on affected versions should update now. Disclosed October 2026, reported by Duc Manh.

Vulnerability Overview

The Mail logging & Catcher plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.2.0 via the 'message' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract valid administrator password-reset keys from stored email logs and complete the WordPress password-reset flow to escalate privileges to administrator. Exploitation requires an administrator to have previously configured the plugin's default_view_role setting to a capability held by low-privileged users such as 'read'; on an untouched install the default of 'manage_options' restricts log access to administrators only.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

Mail logging & Catcher <= 2.2.0 carries this weakness at message, and reaching it takes an account at Subscriber level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For Mail logging & Catcher the fix is 2.3.0: builds <= 2.2.0 are affected, anything from 2.3.0 onward is not.

Remediation

Update to version 2.3.0, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Mail logging & Catcher 2.3.0 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C