WP Fastest Cache <= 1.5.3 - Unauthenticated Sensitive Information Exposure via Cached wp-activate.php Response
Strategic Overview
- Status
- Patched in 1.5.4
- Affected Plugin
- WP Fastest Cache – WordPress Cache Plugin
- Affected Version
<= 1.5.3- CVSS
- 5.9Medium
- Weakness type
- CWE-524 · Use of Cache Containing Sensitive Information
- CVE
CVE-2026-111464
At a glance
CVE-2026-111464 is a medium-severity Use of Cache Containing Sensitive Information vulnerability in the WP Fastest Cache WordPress plugin, affecting versions <= 1.5.3. It carries a CVSS score of 5.9 (reachable over the network; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 1.5.4; sites on affected versions should update now. Disclosed November 2026, reported by R3D.
Vulnerability Overview
The WP Fastest Cache plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.5.3. The plugin caches the response of Core’s wp-activate.php without honoring its no-store/no-cache headers, the wp-activate-* cookie, or the WP_INSTALLING state, writing the credential-bearing activation response to a publicly accessible cache file. This makes it possible for unauthenticated attackers to retrieve the plaintext username and twelve-character password of the most recently activated Multisite registrant from that cached wp-activate.php response. Exploitation requires a Multisite subdirectory installation with public user and site registration enabled, and the credentials are only exposed after a genuine registrant follows their activation link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-524: Use of Cache Containing Sensitive Information
The code uses a cache that contains sensitive information, but the cache can be read by an actor outside of the intended control sphere.
Remediation
Update to version 1.5.4, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: WP Fastest Cache 1.5.4 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in WP Fastest Cache – WordPress Cache Plugin
- 9.8CVE-2023-6063: WP Fastest Cache <= 1.2.1 SQL Injection
CVE-2023-6063 - 9.8CVE-2015-9316: WP Fastest Cache < 0.8.4.9 SQL Injection
CVE-2015-9316 - 9.1CVE-2019-13635: WP Fastest Cache <= 0.8.9.5 Directory Traversal
CVE-2019-13635 - 8.8CVE-2021-24870: WP Fastest Cache CSRF to Stored Cross-Site Scripting
CVE-2021-24870 - 8.8CVE-2021-24869: WP Fastest Cache < 0.9.5 SQL Injection
CVE-2021-24869 - 8.8CVE-2018-17584: WP Fastest Cache <= 0.8.8.5 Cross-Site Request Forgery
CVE-2018-17584 - 8.8WP Fastest Cache <= 0.8.5.9 Local File Inclusion
- 8.8WP Fastest Cache <= 0.8.5.7 Local File Inclusion
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C