CVE-2026-109994

Eventin <= 4.1.29 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure via 'id' Parameter

2026-11-05 20:43
Wordfence PRISM

Strategic Overview

Status
Patched in 4.1.30
Affected Version
<= 4.1.29
CVSS
6.5Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-109994
View all Eventin – Events Calendar, Tickets, Registration, Booking & WooCommerce vulnerabilities

At a glance

CVE-2026-109994 is a medium-severity Missing Authorization vulnerability in the Eventin WordPress plugin, affecting versions <= 4.1.29. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 4.1.30; sites on affected versions should update now. Disclosed November 2026, reported by Wordfence PRISM.

Vulnerability Overview

The Eventin – Events Calendar, Tickets, Registration, Booking & WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.1.29 via the 'id' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the email address and phone number of any WordPress user, including administrators, by supplying their user id in a query-string parameter while placing the authenticated user's own id in the URL path.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-862: Missing Authorization

Reaching this weakness in Eventin <= 4.1.29 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Eventin the fix is 4.1.30: builds <= 4.1.29 are affected, anything from 4.1.30 onward is not.

Remediation

Update to version 4.1.30, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Eventin 4.1.30 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C