WP Data Access <= 5.5.89 - Incorrect Authorization to Unauthenticated Privilege Escalation via 'key' and 'val' Parameters on app/update, app/delete, app/insert
Strategic Overview
- Status
- Patched in 5.5.90
- Affected Version
<= 5.5.89- CVSS
- 8.1High
- Weakness type
- CWE-863 · Incorrect Authorization
- CVE
CVE-2026-118267
At a glance
CVE-2026-118267 is a high-severity Incorrect Authorization vulnerability in the WP Data Access WordPress plugin, affecting versions <= 5.5.89. It carries a CVSS score of 8.1 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 5.5.90; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.
Vulnerability Overview
The WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps plugin for WordPress is vulnerable to Incorrect Authorization leading to Privilege Escalation in all versions up to, and including, 5.5.89 This is due to the plugin's write endpoints (`wpda/app/update`, `wpda/app/delete`, `wpda/app/insert`) passing the attacker-supplied `key` and `val` parameters directly to `$wpdadb->update`, `$wpdadb->delete`, and `$wpdadb->insert` without enforcing the container's row-filter (`defaultWhere`) or per-column allow-list (`isSelected`) restrictions that are correctly applied on the read endpoints. This makes it possible for authenticated attackers, with Subscriber-level access and above, to write to arbitrary rows and columns outside the configured restrictions — including overwriting the `user_pass` field of the WordPress administrator account in `wp_users` — and subsequently authenticate as the administrator, achieving full site takeover. Exploitation requires an administrator to have published a Data App that enables write transactions (update, delete, or insert) for Subscriber-level or anonymous users, which is an explicitly advertised use-case of the plugin. Exploitation by unauthenticated attackers requires that the administrator has published a Data App whose rest_api.authorization is 'anonymous' and whose container has transactions.update (or delete/insert) enabled. On a default installation, where that is not configured, the vulnerability requires attackers with subscriber-level access and above.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-863: Incorrect Authorization
WP Data Access <= 5.5.89 carries this weakness at anonymous, and reaching it takes no account at all. Incorrect authorization means a permission check exists but evaluates the wrong thing, so it passes for callers it was meant to stop.
The action runs for users the code intended to exclude, with the same effect as having no check at all. For WP Data Access the fix is 5.5.90: builds <= 5.5.89 are affected, anything from 5.5.90 onward is not.
Remediation
Update to version 5.5.90, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: WP Data Access 5.5.90 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps
- 7.5CVE-2026-95605: WP Data Access SQL Injection
CVE-2026-95605 - 7.5CVE-2026-93621: WP Data Access SQL Injection
CVE-2026-93621 - 7.5CVE-2026-81293: WP Data Access SQL Injection
CVE-2026-81293 - 7.5CVE-2026-42665: WP Data Access SQL Injection
CVE-2026-42665 - 7.5CVE-2024-12428: WP Data Access SQL Injection
CVE-2024-12428 - 7.5CVE-2023-1874: WP Data Access <= 5.3.7 Privilege Escalation
CVE-2023-1874 - 7.2CVE-2026-66663: WP Data Access Stored XSS
CVE-2026-66663 - 7.2CVE-2021-24866: WP Data Access <= 4.3.1 Admin+ SQL Injection
CVE-2021-24866
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C