CVE-2026-110023

WP Data Access <= 5.5.88 - Missing Authorization to Unauthenticated Sensitive Information Exposure via 'rel_tab' Parameter

2026-10-30 19:25
Kuba

Strategic Overview

Status
Patched in 5.5.89
Affected Version
<= 5.5.88
CVSS
5.9Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-110023
View all WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps vulnerabilities

At a glance

CVE-2026-110023 is a medium-severity Missing Authorization vulnerability in the WP Data Access WordPress plugin, affecting versions <= 5.5.88. It carries a CVSS score of 5.9 (reachable over the network; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 5.5.89; sites on affected versions should update now. Disclosed October 2026, reported by Kuba.

Vulnerability Overview

The WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.5.88 via the 'rel_tab' parameter. This makes it possible for unauthenticated attackers to extract every row and column of the underlying database table backing any anonymously published app, including WordPress user password hashes, email addresses, and password-reset keys from wp_users. Exploitation requires that an administrator has published at least one app with its REST API authorization set to 'anonymous', which is the standard configuration for publicly embedded apps.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-862: Missing Authorization

WP Data Access <= 5.5.88 carries this weakness at rel_tab, and reaching it takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For WP Data Access the fix is 5.5.89: builds <= 5.5.88 are affected, anything from 5.5.89 onward is not.

Remediation

Update to version 5.5.89, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: WP Data Access 5.5.89 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C