CVE-2026-9004

WP-CRM System <= 3.4.6 - Authenticated (Contributor+) Exposure of Sensitive Information via 'contact_id' Parameter

2026-09-21 19:26
Teerachai Somprasong

Strategic Overview

Status
Patched in 3.4.7
Affected Version
<= 3.4.6
CVSS
4.3Medium
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE-2026-9004
View all WP-CRM System – Manage Clients and Projects vulnerabilities

At a glance

CVE-2026-9004 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the WP-CRM System WordPress plugin, affecting versions <= 3.4.6. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 3.4.7; sites on affected versions should update now. Disclosed September 2026, reported by Teerachai Somprasong.

Vulnerability Overview

The WP-CRM System – Manage Clients and Projects plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.4.6 via the 'contact_id' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract full names, email addresses, phone numbers, mobile numbers, fax numbers, and physical address information of arbitrary CRM contact records by enumerating the contact_id parameter.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

WP-CRM System <= 3.4.6 carries this weakness at contact_id, and reaching it takes an account at Contributor level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For WP-CRM System the fix is 3.4.7: builds <= 3.4.6 are affected, anything from 3.4.7 onward is not.

Remediation

Update to version 3.4.7, or a newer patched version

How does WordSec protect against this?

The fix is the thing that ends this: WP-CRM System 3.4.7 closes this, and updating the plugin is the step that ends it.

  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C