WC Shop Sync – Square Payment Gateway and Product Synchronization for WooCommerce <= 4.7.5 - Cross-Site Request Forgery
Strategic Overview
- Status
- Patched in 4.7.6
- Affected Version
<= 4.7.5- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery
- CVE
CVE-2026-119466
At a glance
CVE-2026-119466 is a medium-severity Cross-Site Request Forgery vulnerability in the WC Shop Sync WordPress plugin, affecting versions <= 4.7.5. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.7.6; sites on affected versions should update now. Disclosed October 2026, reported by Oly Hossen.
Vulnerability Overview
The WC Shop Sync – Square Payment Gateway and Product Synchronization for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.7.5. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery
Reaching this weakness in WC Shop Sync <= 4.7.5 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For WC Shop Sync the fix is 4.7.6: builds <= 4.7.5 are affected, anything from 4.7.6 onward is not.
Remediation
Update to version 4.7.6, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to WC Shop Sync: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WC Shop Sync 4.7.6 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in WC Shop Sync – Square Payment Gateway and Product Synchronization for WooCommerce
- 6.5CVE-2026-57810: WC Shop Sync SQL Injection
CVE-2026-57810 - 6.5CVE-2026-45211: APIExperts Square for WooCommerce SQL Injection
CVE-2026-45211 - 6.3CVE-2022-4974: Freemius SDK <= 2.4.2 Missing Authorization Checks
CVE-2022-4974 - 6.1CVE-2024-27959: APIExperts Square for WooCommerce Reflected XSS
CVE-2024-27959 - 6.1CVE-2023-33999: Freemius SDK <= 2.5.9 Reflected Cross-Site Scripting
CVE-2023-33999 - 5.3CVE-2026-115959: WC Shop Sync Missing Authorization
CVE-2026-115959 - 5.3CVE-2026-110367: WC Shop Sync Missing Authorization
CVE-2026-110367 - 5.3CVE-2026-54848: WC Shop Sync Information Exposure
CVE-2026-54848
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C