WooCommerce Extra Product Options Pro <= 3.3.2 - Reflected Cross-Site Scripting via '<fieldname>_start' / '<fieldname>_end' Parameter
Strategic Overview
- Status
- Patched in 3.3.3
- Affected Plugin
- WooCommerce Extra Product Options Pro
- Affected Version
<= 3.3.2- CVSS
- 6.1Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-104926
At a glance
CVE-2026-104926 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the WooCommerce Extra Product Options Pro WordPress plugin, affecting versions <= 3.3.2. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.3.3; sites on affected versions should update now. Disclosed October 2026, reported by theviper17y.
Vulnerability Overview
The WooCommerce Extra Product Options Pro plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the '<fieldname>_start / <fieldname>_end' parameter in all versions up to, and including, 3.3.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This vulnerability is only exploitable on product pages where a Date & Time Range Picker extra field is configured, though the required field name is visible in the product page source and requires no prior knowledge to discover.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in WooCommerce Extra Product Options Pro <= 3.3.2 takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For WooCommerce Extra Product Options Pro the fix is 3.3.3: builds <= 3.3.2 are affected, anything from 3.3.3 onward is not.
Remediation
Update to version 3.3.3, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to WooCommerce Extra Product Options Pro: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WooCommerce Extra Product Options Pro 3.3.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C