Sadad QA Payment <= 1.28 - Payment Verification Bypass to Unauthenticated Arbitrary Order Payment Confirmation
Strategic Overview
- Status
- Patched in 1.29
- Affected Plugin
- Sadad QA Payment
- Affected Version
<= 1.28- CVSS
- 5.3Medium
- Weakness type
- CWE-602 · Client-Side Enforcement of Server-Side Security
- CVE
CVE-2026-103330
At a glance
CVE-2026-103330 is a medium-severity Client-Side Enforcement of Server-Side Security vulnerability in the Sadad QA Payment WordPress plugin, affecting versions <= 1.28. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.29; sites on affected versions should update now. Disclosed October 2026, reported by Naoki Kawahigashi.
Vulnerability Overview
The Sadad QA Payment plugin for WordPress is vulnerable to Payment Verification Bypass in all versions up to, and including, 1.28. This is due to a payment notification verification mechanism that defaults to an empty merchant secret while allowing the attacker to control the remaining signed data, making signature forgery trivial. This makes it possible for unauthenticated attackers to forge a valid payment notification signature and mark arbitrary orders as paid without completing any actual payment.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-602: Client-Side Enforcement of Server-Side Security
The product includes a server that relies on the client to implement a protection mechanism that is intended to protect the server.
Remediation
Update to version 1.29, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Sadad QA Payment 1.29 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C