CVE-2026-93370

Paystack WooCommerce Payment Gateway <= 5.8.5 - Unauthenticated Sensitive Information Exposure in 'key' Parameter on order-pay Endpoint

Strategic Overview

Status
Patched in 5.8.6
Affected Version
<= 5.8.5
CVSS
5.3Medium
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE-2026-93370
View all Paystack WooCommerce Payment Gateway vulnerabilities

At a glance

CVE-2026-93370 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Paystack WooCommerce Payment Gateway WordPress plugin, affecting versions <= 5.8.5. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 5.8.6; sites on affected versions should update now. Disclosed November 2026, reported by Osvaldo Noe Gonzalez Del Rio (Os).

Vulnerability Overview

The Paystack WooCommerce Payment Gateway plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.8.5 via the 'key' parameter. This makes it possible for unauthenticated attackers to extract customer PII — including billing name, email address, phone number, billing address, shipping address, and purchased product list — embedded into page HTML via wp_localize_script by enumerating sequential order IDs. This is only exploitable when the merchant has enabled the optional custom metadata feature in the Paystack gateway settings.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Paystack WooCommerce Payment Gateway <= 5.8.5 carries this weakness at key, and reaching it takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Paystack WooCommerce Payment Gateway the fix is 5.8.6: builds <= 5.8.5 are affected, anything from 5.8.6 onward is not.

Remediation

Update to version 5.8.6, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Paystack WooCommerce Payment Gateway 5.8.6 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C