CVE-2026-87964

Product Feed Manager for WooCommerce <= 8.0.26 - Authenticated (Shop Manager+) PHP Code Injection via eval() via 'feedConfigCustom2' Parameter

2026-11-05 00:00
Wordfence PRISM

Strategic Overview

At a glance

CVE-2026-87964 is a high-severity Improper Control of Generation of Code vulnerability in the Product Feed Manager for WooCommerce WordPress plugin, affecting versions <= 8.0.26. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Shop Manager level or above. The issue is fixed in version 8.0.27; sites on affected versions should update now. Disclosed November 2026, reported by Wordfence PRISM.

Vulnerability Overview

The Product Feed Manager for WooCommerce – CTX Feed – Support 220+ Shopping, AI & Social Channels plugin for WordPress is vulnerable to PHP Code Injection in all versions up to, and including, 8.0.26. This is due to insufficient sanitization of the `feedConfigCustom2` parameter — only `wp_unslash()` is applied before the value is stored verbatim via `update_option()`, and during feed generation the `Custom2Template::evaluate_return()` method passes the stored `{(return ...)}` template expressions directly to PHP's `eval()` function without any code-level sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to inject and execute arbitrary PHP code on the server, escalating their privileges beyond what the role normally permits to full remote code execution and site takeover. The `ctxfeed_custom2_eval_enabled` option defaults to `true`, meaning no additional administrator configuration is required for this attack path to be exploitable out of the box.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-94: Improper Control of Generation of Code

Product Feed Manager for WooCommerce <= 8.0.26 carries this weakness at wp_unslash(), and reaching it takes an account at Shop Manager level or above. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.

The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Product Feed Manager for WooCommerce the fix is 8.0.27: builds <= 8.0.26 are affected, anything from 8.0.27 onward is not.

Remediation

Update to version 8.0.27, or a newer patched version

How does WordSec protect against this?

An attacker needs Shop Manager access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Product Feed Manager for WooCommerce 8.0.27 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C