VOD Infomaniak <= 1.5.15 - Missing Authorization to Authenticated (Subscriber+) Unauthorized Video Importation via vodimportvideo AJAX Action
Strategic Overview
- Status
- Patched in 1.5.16
- Affected Plugin
- VOD Infomaniak
- Affected Version
<= 1.5.15- CVSS
- 4.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-115831
At a glance
CVE-2026-115831 is a medium-severity Missing Authorization vulnerability in the VOD Infomaniak WordPress plugin, affecting versions <= 1.5.15. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.5.16; sites on affected versions should update now. Disclosed November 2026, reported by Wordfence PRISM.
Vulnerability Overview
The VOD Infomaniak plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.5.15. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to initiate unauthorized video imports using the site owner's Infomaniak API credentials, consume the site owner's VOD account quota, and insert arbitrary rows into the wp_vod_upload table causing public shortcodes to resolve to attacker-chosen video content. This action is explicitly reserved for Contributor-level and above by the plugin's own role-rights system, meaning subscriber access is intentionally forbidden by design — the AJAX handler simply omits the enforcement.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in VOD Infomaniak <= 1.5.15 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For VOD Infomaniak the fix is 1.5.16: builds <= 1.5.15 are affected, anything from 1.5.16 onward is not.
Remediation
Update to version 1.5.16, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: VOD Infomaniak 1.5.16 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in VOD Infomaniak
- 7.2CVE-2026-114695: VOD Infomaniak <= 1.5.14 Stored Cross-Site Scripting
CVE-2026-114695 - 7.2CVE-2025-62020: VOD Infomaniak <= 1.5.11 Stored Cross-Site Scripting
CVE-2025-62020 - 6.1CVE-2024-33571: VOD Infomaniak <= 1.5.6 Reflected Cross-Site Scripting
CVE-2024-33571 - 4.3CVE-2024-49274: VOD Infomaniak <= 1.5.7 Cross-Site Request Forgery
CVE-2024-49274
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C