CVE-2026-111120

VikRentCar Car Rental Management System <= 1.4.8 - Cross-Site Request Forgery to Remote Code Execution via 'condtext_update_tmpl' AJAX Task

2026-10-27 18:29
Wordfence PRISM

Strategic Overview

Status
Patched in 1.4.9
Affected Version
<= 1.4.8
CVSS
8.8High
Weakness type
CWE-352 · Cross-Site Request Forgery (CSRF)
CVE
CVE-2026-111120
View all VikRentCar Car Rental Management System vulnerabilities

At a glance

CVE-2026-111120 is a high-severity Cross-Site Request Forgery (CSRF) vulnerability in the VikRentCar Car Rental Management System WordPress plugin, affecting versions <= 1.4.8. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 1.4.9; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.

Vulnerability Overview

The VikRentCar Car Rental Management System plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.8. This is due to missing or incorrect nonce validation on the condtext_update_tmpl function. This makes it possible for unauthenticated attackers to write arbitrary PHP code to the plugin's executable template files such as site/helpers/email_tmpl.php, which are later include()d by loadEmailTemplate() and loadPdfTemplate(), achieving remote code execution on the server via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The injected PHP payload bypasses sanitization because the plugin's own __PHP_OPEN__/__PHP_CLOSE__ placeholder expansion and cleanPHPSourceCode() logic explicitly reverse both sanitize_text_field filtering and saveHTML() HTML-encoding, restoring a literal <?php...?> payload to live PHP before it is written to disk. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-352: Cross-Site Request Forgery (CSRF)

VikRentCar Car Rental Management System <= 1.4.8 carries this weakness at include(), and reaching it takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For VikRentCar Car Rental Management System the fix is 1.4.9: builds <= 1.4.8 are affected, anything from 1.4.9 onward is not.

Remediation

Update to version 1.4.9, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to VikRentCar Car Rental Management System: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: VikRentCar Car Rental Management System 1.4.9 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C