Uncanny Automator – Claude & ChatGPT MCP Server with MCP for AI Automation <= 7.7.1 - Missing Authorization
Strategic Overview
- Status
- Patched in 8.0.0
- Affected Version
<= 7.7.1- CVSS
- 5.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-120846
At a glance
CVE-2026-120846 is a medium-severity Missing Authorization vulnerability in the Uncanny Automator WordPress plugin, affecting versions <= 7.7.1. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 8.0.0; sites on affected versions should update now. Disclosed November 2026, reported by nguyen viet tin.
Vulnerability Overview
The Uncanny Automator – Claude & ChatGPT MCP Server with MCP for AI Automation plugin for WordPress is vulnerable to unauthorized access in all versions up to, and including, 7.7.1. This is due to a missing capability check on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in Uncanny Automator <= 7.7.1 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Uncanny Automator the fix is 8.0.0: builds <= 7.7.1 are affected, anything from 8.0.0 onward is not.
Remediation
Update to version 8.0.0, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Uncanny Automator 8.0.0 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
- 8.8CVE-2025-2075: Uncanny Automator Authenticated (Subscriber+)
CVE-2025-2075 - 7.5CVE-2026-15025: Uncanny Automator Authenticated (Subscriber+)
CVE-2026-15025 - 6.5CVE-2025-48133: Uncanny Automator Missing Authorization
CVE-2025-48133 - 5.4CVE-2025-4520: Uncanny Automator Authenticated (Subscriber+) Plugin
CVE-2025-4520
Other vulnerabilities in Uncanny Automator – Claude & ChatGPT MCP Server with MCP for AI Automation
- 9.1CVE-2025-3623: Uncanny Automator PHP Object Injection
CVE-2025-3623 - 8.1CVE-2026-15008: Uncanny Automator PHP Object Injection
CVE-2026-15008 - 8.1CVE-2026-56031: Uncanny Automator PHP Object Injection
CVE-2026-56031 - 7.5CVE-2026-82627: Uncanny Automator PHP Object Injection
CVE-2026-82627 - 7.2CVE-2026-2269: Uncanny Automator SSRF to Arbitrary File Upload
CVE-2026-2269 - 6.4CVE-2025-15522: Uncanny Automator Stored XSS
CVE-2025-15522 - 5.5CVE-2024-13838: Uncanny Automator SSRF
CVE-2024-13838 - 5.4Uncanny Automator <= 4.14 Cross-Site Request Forgery
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C