TranslatePress <= 3.3.8 - Unauthenticated Stored Cross-Site Scripting via Comment Content via trp-gettext Marker Smuggling and PCRE Backtrack Bypass
Strategic Overview
- Status
- Patched in 3.3.9
- Affected Version
<= 3.3.8- CVSS
- 7.2High
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-119167
At a glance
CVE-2026-119167 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the TranslatePress WordPress plugin, affecting versions <= 3.3.8. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.3.9; sites on affected versions should update now. Disclosed November 2026, reported by UKO.
Vulnerability Overview
The TranslatePress – Translate Multilingual sites with AI Translation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.3.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires that at least one prior comment from the attacker's name and email pair has been approved under WordPress's default comment_previously_approved moderation setting, and that a secondary language is configured in TranslatePress.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
TranslatePress <= 3.3.8 carries this weakness at comment, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For TranslatePress the fix is 3.3.9: builds <= 3.3.8 are affected, anything from 3.3.9 onward is not.
Remediation
Update to version 3.3.9, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: TranslatePress 3.3.9 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2026-120537: TranslatePress <= 3.3.8 Stored Cross-Site Scripting
CVE-2026-120537 - 7.2CVE-2026-107768: TranslatePress <= 3.3.7 Stored Cross-Site Scripting
CVE-2026-107768 - 7.2CVE-2026-103062: TranslatePress Stored XSS
CVE-2026-103062 - 7.2CVE-2026-89412: TranslatePress <= 3.3.5 Stored Cross-Site Scripting
CVE-2026-89412
Other vulnerabilities in TranslatePress – Translate Multilingual sites with AI Translation
- 9.8CVE-2026-19632: TranslatePress – Multilingual Account Takeover
CVE-2026-19632 - 8.1CVE-2025-58592: TranslatePress <= 2.10.2 PHP Object Injection
CVE-2025-58592 - 7.3CVE-2026-78267: TranslatePress Privilege Escalation
CVE-2026-78267 - 7.2CVE-2026-76053: TranslatePress <= 3.3.3 Stored Cross-Site Scripting
CVE-2026-76053 - 7.2CVE-2026-66582: TranslatePress Stored XSS
CVE-2026-66582 - 7.2CVE-2026-75981: TranslatePress Stored XSS
CVE-2026-75981 - 7.2CVE-2026-18510: TranslatePress <= 3.2.6 Stored Cross-Site Scripting
CVE-2026-18510 - 7.2CVE-2025-30773: TranslatePress <= 2.9.6 PHP Object Injection
CVE-2025-30773
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C