CVE-2026-119089

ThirstyAffiliates <= 3.12.1 - Unauthenticated Stored Cross-Site Scripting via Comment Content via <ta> Tag

2026-10-30 17:47
Sawyer

Strategic Overview

Status
Patched in 3.12.2
Affected Version
<= 3.12.1
CVSS
7.2High
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-119089
View all ThirstyAffiliates – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin vulnerabilities

At a glance

CVE-2026-119089 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the ThirstyAffiliates WordPress plugin, affecting versions <= 3.12.1. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.12.2; sites on affected versions should update now. Disclosed October 2026, reported by Sawyer.

Vulnerability Overview

The ThirstyAffiliates – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.12.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable on block themes (such as Twenty Twenty-Five) where the Comment Content block causes comment HTML to flow through render_block, triggering the plugin's transformer. Additionally, a successful attack requires the attacker to have had one prior comment approved, after which subsequent crafted comments are auto-approved and rendered publicly.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

ThirstyAffiliates <= 3.12.1 carries this weakness at comment, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For ThirstyAffiliates the fix is 3.12.2: builds <= 3.12.1 are affected, anything from 3.12.2 onward is not.

Remediation

Update to version 3.12.2, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: ThirstyAffiliates 3.12.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C