Themify Builder <= 7.8.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'variations' Repeater Field
Strategic Overview
- Status
- Patched in 7.8.5
- Affected Plugin
- Themify Builder
- Affected Version
<= 7.8.4- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-115869
At a glance
CVE-2026-115869 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Themify Builder WordPress plugin, affecting versions <= 7.8.4. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 7.8.5; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.
Vulnerability Overview
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'variations' repeater field of Custom Font (tb_cf) posts in versions up to, and including, 7.8.4. This is due to insufficient input sanitization and output escaping on the variations post meta: Themify_Metabox::_save_meta() only passes the value through wp_kses_data() when the field type is 'textbox' or 'textarea', so the 'repeater' field writes attacker-controlled sub-fields (style, woff/woff2/ttf/svg/eot URLs) to update_post_meta() verbatim, and Themify_Custom_Fonts::render_columns() later echoes those values unescaped inside a <style> block on the Custom Fonts admin listing. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page (specifically, the Custom Fonts admin listing).
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Themify Builder <= 7.8.4 carries this weakness at variations, and reaching it takes an account at Contributor level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Themify Builder the fix is 7.8.5: builds <= 7.8.4 are affected, anything from 7.8.5 onward is not.
Remediation
Update to version 7.8.5, or a newer patched version
How does WordSec protect against this?
An attacker needs Contributor access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Themify Builder 7.8.5 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2026-95864: Themify Builder <= 7.8.1 Stored Cross-Site Scripting
CVE-2026-95864 - 7.2CVE-2026-57369: Themify Builder <= 7.7.4 Stored Cross-Site Scripting
CVE-2026-57369 - 6.4CVE-2026-111726: Themify Builder <= 7.8.2 Stored Cross-Site Scripting
CVE-2026-111726 - 6.4CVE-2026-15096: Themify Builder <= 7.7.6 Stored Cross-Site Scripting
CVE-2026-15096
Other vulnerabilities in Themify Builder
- 8.8CVE-2024-56216: Themify Builder <= 7.6.3 Local File Inclusion
CVE-2024-56216 - 7.5CVE-2026-96831: Themify Builder <= 7.8.1 PHP Object Injection
CVE-2026-96831 - 6.4CVE-2026-15097: Themify Builder <= 7.7.6 Stored Cross-Site Scripting
CVE-2026-15097 - 6.4CVE-2025-9353: Themify Builder <= 7.6.9 Stored Cross-Site Scripting
CVE-2025-9353 - 6.4CVE-2024-52423: Themify Builder <= 7.6.5 Stored Cross-Site Scripting
CVE-2024-52423 - 6.1CVE-2024-13319: Themify Builder <= 7.6.5 Reflected XSS
CVE-2024-13319 - 6.1CVE-2024-9385: Themify Builder <= 7.6.2 Reflected Cross-Site Scripting
CVE-2024-9385 - 6.1CVE-2024-3032: Themify Builder <= 7.5.7 Open Redirect
CVE-2024-3032
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C