tagDiv Composer <= 5.4.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
Strategic Overview
- Status
- Patched in 5.4.8
- Affected Plugin
- tagDiv Composer
- Affected Version
<= 5.4.7- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-12561
At a glance
CVE-2026-12561 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the tagDiv Composer WordPress plugin, affecting versions <= 5.4.7. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 5.4.8; sites on affected versions should update now. Disclosed August 2026, reported by Truoc Phan.
Vulnerability Overview
The tagDiv Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the vc_raw_html shortcode in all versions up to and including 5.4.7. This is due to insufficient input sanitization and output escaping in the vc_raw_html::render() method, which base64-decodes shortcode content (after a strip_tags() that is bypassed because the encoded payload contains no tags on save) and concatenates the result directly into the page HTML. Because WordPress's save-time wp_kses_post() filter only sees the inert base64 text inside a normal shortcode bracket and does not decode it, the dangerous tags survive into post_content and are emitted unescaped at render time. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page (for example, when an Editor or Administrator previews the pending post).
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
tagDiv Composer <= 5.4.7 carries this weakness at render(), and reaching it takes an account at Contributor level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For tagDiv Composer the fix is 5.4.8: builds <= 5.4.7 are affected, anything from 5.4.8 onward is not.
Remediation
Update to version 5.4.8, or a newer patched version
How does WordSec protect against this?
An attacker needs Contributor access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: tagDiv Composer 5.4.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
- 7.2CVE-2025-62031: tagDiv Composer <= 5.4.1 Stored Cross-Site Scripting
CVE-2025-62031 - 7.2CVE-2023-3169: tagDiv Composer <= 4.1 Stored Cross-Site Scripting
CVE-2023-3169 - 6.4CVE-2026-39692: tagDiv Composer <= 5.4.4 Stored Cross-Site Scripting
CVE-2026-39692 - 6.4CVE-2025-50005: tagDiv Composer <= 5.4.2 Stored Cross-Site Scripting
CVE-2025-50005
Other vulnerabilities in tagDiv Composer
- 9.8CVE-2024-13645: TagDiv Composer Arbitrary PHP Object Instantiation
CVE-2024-13645 - 9.8CVE-2022-3477: tagDiv Composer Unauthorized Account Access
CVE-2022-3477 - 8.8CVE-2024-3813: tagDiv Composer <= 4.8 Local File Inclusion
CVE-2024-3813 - 6.5CVE-2026-39712: tagDiv Composer <= 5.4.4 Arbitrary Shortcode Execution
CVE-2026-39712 - 6.4CVE-2025-62030: tagDiv Composer <= 5.4.1 Stored Cross-Site Scripting
CVE-2025-62030 - 6.4CVE-2025-3510: tagDiv Composer <= 5.4 Stored Cross-Site Scripting
CVE-2025-3510 - 6.4CVE-2024-3888: tagDiv Composer <= 4.8 Stored Cross-Site Scripting
CVE-2024-3888 - 6.1CVE-2026-57734: tagDiv Composer <= 5.4.5 Reflected XSS
CVE-2026-57734
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C