SureDash – Community, Courses & Member Dashboard <= 1.12.3 - Authenticated (Subscriber+) Arbitrary File Deletion
Strategic Overview
- Status
- Patched in 1.12.4
- Affected Plugin
- SureDash – Community, Courses & Member Dashboard
- Affected Version
<= 1.12.3- CVSS
- 8.1High
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory
- CVE
CVE-2026-115604
At a glance
CVE-2026-115604 is a high-severity Improper Limitation of a Pathname to a Restricted Directory vulnerability in the SureDash WordPress plugin, affecting versions <= 1.12.3. It carries a CVSS score of 8.1 (reachable over the network; low attack complexity; high integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.12.4; sites on affected versions should update now. Disclosed October 2026, reported by yzx001.
Vulnerability Overview
The SureDash – Community, Courses & Member Dashboard plugin for WordPress is vulnerable to Arbitrary File Deletion due to insufficient file path validation in all versions up to, and including, 1.12.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on integrity, availability.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory
Reaching this weakness in SureDash <= 1.12.3 takes an account at Subscriber level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For SureDash the fix is 1.12.4: builds <= 1.12.3 are affected, anything from 1.12.4 onward is not.
Remediation
Update to version 1.12.4, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: SureDash 1.12.4 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in SureDash – Community, Courses & Member Dashboard
- 8.8CVE-2025-48164: SureDash <= 1.0.3 Privilege Escalation
CVE-2025-48164 - 7.2CVE-2026-66698: SureDash Stored XSS
CVE-2026-66698 - 6.5CVE-2026-54813: SureDash SQL Injection
CVE-2026-54813 - 6.4CVE-2026-110881: SureDash Stored XSS
CVE-2026-110881 - 6.4CVE-2026-96870: SureDash <= 1.12.0 Stored Cross-Site Scripting
CVE-2026-96870 - 6.4CVE-2026-102774: SureDash <= 1.12.1 Stored DOM-Based XSS
CVE-2026-102774 - 6.4CVE-2026-18402: SureDash <= 1.10.3 Stored Cross-Site Scripting
CVE-2026-18402 - 6.4CVE-2026-15821: SureDash <= 1.10.0 Stored Cross-Site Scripting
CVE-2026-15821
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C