SSL Zen — SSL Certificate Installer & HTTPS Redirects < 4.7.40 - Authenticated (Subscriber+) Information Exposure
Strategic Overview
- Status
- Patched in 4.7.40
- Affected Plugin
- SSL Zen — SSL Certificate Installer & HTTPS Redirects
- Affected Version
< 4.7.40- CVSS
- 4.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-86781
At a glance
CVE-2026-86781 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the SSL Zen WordPress plugin, affecting versions < 4.7.40. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 4.7.40; sites on affected versions should update now. Disclosed September 2026, reported by Suhayb Ahmed.
Vulnerability Overview
The SSL Zen — SSL Certificate Installer & HTTPS Redirects plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to 4.7.40. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive user or configuration data.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in SSL Zen < 4.7.40 takes an account at Subscriber level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For SSL Zen the fix is 4.7.40: builds < 4.7.40 are affected, anything from 4.7.40 onward is not.
Remediation
Update to version 4.7.40, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: SSL Zen 4.7.40 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in SSL Zen — SSL Certificate Installer & HTTPS Redirects
- 6.3CVE-2022-4974: Freemius SDK <= 2.4.2 Missing Authorization Checks
CVE-2022-4974 - 6.1CVE-2026-17577: SSL Zen <= 4.7.42 Reflected Cross-Site Scripting
CVE-2026-17577 - 6.1CVE-2026-15463: SSL Zen <= 4.7.42 Reflected Cross-Site Scripting
CVE-2026-15463 - 6.1CVE-2026-28569: SSL Zen Reflected XSS
CVE-2026-28569 - 6.1CVE-2023-33999: Freemius SDK <= 2.5.9 Reflected Cross-Site Scripting
CVE-2023-33999 - 5.3CVE-2024-1076: SSL Zen Info Exposure
CVE-2024-1076 - 4.9CVE-2026-17602: SSL Zen Path Traversal to Arbitrary File Read
CVE-2026-17602
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C