Page Builder by SiteOrigin < 2.38.0 - Authenticated (Contributor+) Information Exposure
Strategic Overview
- Status
- Patched in 2.38.0
- Affected Plugin
- Page Builder by SiteOrigin
- Affected Version
< 2.38.0- CVSS
- 4.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-110507
At a glance
CVE-2026-110507 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Page Builder by SiteOrigin WordPress plugin, affecting versions < 2.38.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 2.38.0; sites on affected versions should update now. Disclosed October 2026, reported by Karthik.
Vulnerability Overview
The Page Builder by SiteOrigin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to 2.38.0. This makes it possible for authenticated attackers, with contributor-level access and above, to extract sensitive user or configuration data.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Page Builder by SiteOrigin < 2.38.0 takes an account at Contributor level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Page Builder by SiteOrigin the fix is 2.38.0: builds < 2.38.0 are affected, anything from 2.38.0 onward is not.
Remediation
Update to version 2.38.0, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: Page Builder by SiteOrigin 2.38.0 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in Page Builder by SiteOrigin
- 8.8CVE-2026-2448: Page Builder by SiteOrigin <= 2.33.5 LFI
CVE-2026-2448 - 8.8CVE-2020-13643: Page Builder by SiteOrigin CSRF
CVE-2020-13643 - 8.8CVE-2020-13642: Page Builder by SiteOrigin CSRF
CVE-2020-13642 - 6.6CVE-2026-97256: Page Builder by SiteOrigin PHP Object Injection
CVE-2026-97256 - 6.4CVE-2026-110506: Page Builder by SiteOrigin < 2.38.0 Stored XSS
CVE-2026-110506 - 6.4CVE-2026-13295: Page Builder by SiteOrigin <= 2.34.3 Stored XSS
CVE-2026-13295 - 6.4CVE-2025-1459: Page Builder by SiteOrigin <= 2.31.4 Stored XSS
CVE-2025-1459 - 6.4CVE-2024-12240: Page Builder by SiteOrigin <= 2.31.0 Stored XSS
CVE-2024-12240
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C