CVE-2026-114443

Security by CleanTalk <= 2.190 - Unauthenticated Authentication Bypass

2026-10-28 00:00
Karthik

Strategic Overview

Status
Patched in 2.191
Affected Version
<= 2.190
CVSS
8.1High
Weakness type
CWE-287 · Improper Authentication
CVE
CVE-2026-114443
View all Security Plugin, Firewall & Malware Scanner with Auto Removal vulnerabilities

At a glance

CVE-2026-114443 is a high-severity Improper Authentication vulnerability in the Security Plugin, Firewall & Malware Scanner with Auto Removal WordPress plugin, affecting versions <= 2.190. It carries a CVSS score of 8.1 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 2.191; sites on affected versions should update now. Disclosed October 2026, reported by Karthik.

Vulnerability Overview

The Security by CleanTalk plugin for WordPress is vulnerable to Two-Factor Authentication Bypass in all versions up to, and including, 2.190. This is due to missing verification that the first authentication factor (password) had been successfully completed before accepting a submitted authenticator-app or email two-factor code, allowing the second factor to be submitted in isolation. This makes it possible for unauthenticated attackers to log in as any user who has two-factor authentication enabled, including administrators, by supplying only a valid TOTP code without knowing the account password. Two-factor authentication must be enabled for the targeted user account.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-287: Improper Authentication

Reaching this weakness in Security Plugin, Firewall & Malware Scanner with Auto Removal <= 2.190 takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.

An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Security Plugin, Firewall & Malware Scanner with Auto Removal the fix is 2.191: builds <= 2.190 are affected, anything from 2.191 onward is not.

Remediation

Update to version 2.191, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Security Plugin, Firewall & Malware Scanner with Auto Removal 2.191 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C