Royal MCP – Secure AI Connector for Claude, ChatGPT & any LLM via MCP < 1.5.7 - Authentication Bypass
Strategic Overview
- Status
- Patched in 1.5.7
- Affected Version
< 1.5.7- CVSS
- 7.5High
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-111958
At a glance
CVE-2026-111958 is a high-severity Improper Authentication vulnerability in the Royal MCP WordPress plugin, affecting versions < 1.5.7. It carries a CVSS score of 7.5 (reachable over the network; high confidentiality, integrity, availability impact). The issue is fixed in version 1.5.7; sites on affected versions should update now. Disclosed October 2026, reported by Raphael P. Cigana.
Vulnerability Overview
The Royal MCP – Secure AI Connector for Claude, ChatGPT & any LLM via MCP plugin for WordPress is vulnerable to Authentication Bypass in all versions up to 1.5.7 (exclusive). This makes it possible for authenticated attackers, with access to a valid token, to bypass authentication and access the full REST API.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-287: Improper Authentication
Reaching this weakness in Royal MCP < 1.5.7 takes a caller who can reach the endpoint. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Royal MCP the fix is 1.5.7: builds < 1.5.7 are affected, anything from 1.5.7 onward is not.
Remediation
Update to version 1.5.7, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Royal MCP 1.5.7 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Royal MCP – Secure AI Connector for Claude, ChatGPT & any LLM via MCP
- 5.3CVE-2026-10750: Royal MCP <= 1.4.25 Unauthenticated MCP Tool Use
CVE-2026-10750 - 5.3CVE-2026-40775: Royal MCP Missing Authorization
CVE-2026-40775 - 4.3CVE-2026-111961: Royal MCP Missing Authorization
CVE-2026-111961 - 4.3CVE-2026-111960: Royal MCP Missing Authorization
CVE-2026-111960 - 4.3CVE-2026-54842: Royal MCP Missing Authorization
CVE-2026-54842
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C