CVE-2026-97255

Royal Addons for Elementor – Addons and Templates Kit for Elementor <= 1.7.1069 - Unauthenticated Insecure Direct Object Reference

Strategic Overview

Status
Patched in 1.7.1070
Affected Version
<= 1.7.1069
CVSS
5.3Medium
Weakness type
CWE-639 · Authorization Bypass Through User-Controlled Key
CVE
CVE-2026-97255
View all Royal Addons for Elementor – Addons and Templates Kit for Elementor vulnerabilities

At a glance

CVE-2026-97255 is a medium-severity Authorization Bypass Through User-Controlled Key vulnerability in the Royal Addons for Elementor WordPress plugin, affecting versions <= 1.7.1069. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.7.1070; sites on affected versions should update now. Disclosed October 2026, reported by Anthony Green of Greenhat Security.

Vulnerability Overview

The Royal Addons for Elementor – Addons and Templates Kit for Elementor plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.7.1069. This is due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-639: Authorization Bypass Through User-Controlled Key

Reaching this weakness in Royal Addons for Elementor <= 1.7.1069 takes no account at all. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.

Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For Royal Addons for Elementor the fix is 1.7.1070: builds <= 1.7.1069 are affected, anything from 1.7.1070 onward is not.

Remediation

Update to version 1.7.1070, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Royal Addons for Elementor 1.7.1070 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C