CVE-2026-107100

Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.81 - 1.7.1069 - Unauthenticated Information Exposure

2026-10-28 00:00
Maciek Komorowski

Strategic Overview

Status
Patched in 1.7.1070
Affected Version
1.3.81 – 1.7.1069
CVSS
5.3Medium
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE-2026-107100
View all Royal Addons for Elementor – Addons and Templates Kit for Elementor vulnerabilities

At a glance

CVE-2026-107100 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Royal Addons for Elementor WordPress plugin, affecting versions 1.3.81 – 1.7.1069. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.7.1070; sites on affected versions should update now. Disclosed October 2026, reported by Maciek Komorowski.

Vulnerability Overview

The Royal Addons for Elementor – Addons and Templates Kit for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in versions 1.3.81 through 1.7.1069. This makes it possible for unauthenticated attackers to extract sensitive user or configuration data.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Reaching this weakness in Royal Addons for Elementor 1.3.81 – 1.7.1069 takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Royal Addons for Elementor the fix is 1.7.1070: builds 1.3.81 – 1.7.1069 are affected, anything from 1.7.1070 onward is not.

Remediation

Update to version 1.7.1070, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Royal Addons for Elementor 1.7.1070 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C