CVE-2026-106647

Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.68 - 1.7.1069 - Missing Authorization

2026-10-28 00:00
Mohammed Abd Alrahman

Strategic Overview

Status
Patched in 1.7.1070
Affected Version
1.3.68 – 1.7.1069
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-106647
View all Royal Addons for Elementor – Addons and Templates Kit for Elementor vulnerabilities

At a glance

CVE-2026-106647 is a medium-severity Missing Authorization vulnerability in the Royal Addons for Elementor WordPress plugin, affecting versions 1.3.68 – 1.7.1069. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). The root cause is a missing authorization check on a reachable function. The issue is fixed in version 1.7.1070; sites on affected versions should update now. Disclosed October 2026, reported by Mohammed Abd Alrahman.

Vulnerability Overview

The Royal Addons for Elementor – Addons and Templates Kit for Elementor plugin for WordPress is vulnerable to unauthorized access in versions 1.3.68 through 1.7.1069. This is due to a missing capability check on a function. This makes it possible for authenticated attackers, with author-level access and above, to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Royal Addons for Elementor 1.3.68 – 1.7.1069 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Royal Addons for Elementor the fix is 1.7.1070: builds 1.3.68 – 1.7.1069 are affected, anything from 1.7.1070 onward is not.

Remediation

Update to version 1.7.1070, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Royal Addons for Elementor 1.7.1070 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C